        <!DOCTYPE html><html lang="en-US"
	itemscope 
	itemtype="http://schema.org/Article" 
	prefix="og: http://ogp.me/ns#" >
    	<head>

		        <meta charset="UTF-8">
        <meta name="viewport" content="width=device-width, initial-scale=1">
        <link rel="profile" href="http://gmpg.org/xfn/11">
        <link rel="pingback" href="http://karnac.com/flanews/xmlrpc.php">
    <title>MOTHER NATURE IS THE BIG WINNER AGAIN AT AUBURNDALE SPEEDWAY BUT SOME RACES DO GET RUN | Karnac Racing News</title>

<!-- All in One SEO Pack 2.3.4.2 by Michael Torbert of Semper Fi Web Design[387,507] -->
<link rel="author" href="http://scott" />

<link rel="canonical" href="http://karnac.com/flanews/tracks/auburndale-speedway/mother-nature-is-the-big-winner-again-at-auburndale-speedway-but-some-races-do-get-run/" />
<meta property="og:title" content="MOTHER NATURE IS THE BIG WINNER AGAIN AT AUBURNDALE SPEEDWAY BUT SOME RACES DO GET RUN | Karnac Racing News" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://karnac.com/flanews/tracks/auburndale-speedway/mother-nature-is-the-big-winner-again-at-auburndale-speedway-but-some-races-do-get-run/" />
<meta property="og:image" content="http://karnac.com/flanews/wp-content/uploads/2017/10/Chris-Narramore-Sr.-honored-his-late-friend-Randy-King-with-a-victory-in-the-Q-Mini-Stocks.._-002-840x840.jpg" />
<meta property="og:site_name" content="Karnac Racing News" />
<meta property="fb:admins" content="scott@karnac.com" />
<meta property="fb:app_id" content="1477858575609869" />
<meta property="og:description" content="&quot;I keep waiting for an ark to float by&quot; were the words of Auburndale Speedway owner Rex Guy as, once again, rain canceled one full racing program and interrupted another this weekend. Saturday night the heat races were just about completed when rain hit the speedway. However, the shower lasted just a few minutes and track crews went to work drying the speedway. The extra heavy humidity caused it to take over an hour to dry the surface, but all of the features except two were run. The scheduled SSCS Modified event was not going to be run as most of the drivers opted not to take the chance to travel to the track because of the bad forecast. The Mini Cup drivers in attendance opted not to run their feature because of unsafe conditions regarding a very wet infield which could have played havoc with the small cars had they gotten into the soaked infield area. The Legend Cars, Q mini Stocks, Scramblers and Figure-8s were able to race and put on a good show for the dampened crowd. Taylor" />
<meta property="article:tag" content="auburndale speedway" />
<meta property="article:tag" content="local" />
<meta property="article:tag" content="racing news" />
<meta property="article:published_time" content="2017-10-10T15:05:08Z" />
<meta property="article:modified_time" content="2017-10-10T15:05:08Z" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:title" content="MOTHER NATURE IS THE BIG WINNER AGAIN AT AUBURNDALE SPEEDWAY BUT SOME RACES DO GET RUN | Karnac Racing News" />
<meta name="twitter:description" content="&quot;I keep waiting for an ark to float by&quot; were the words of Auburndale Speedway owner Rex Guy as, once again, rain canceled one full racing program and interrupted another this weekend. Saturday night the heat races were just about completed when rain hit the speedway. However, the shower lasted just a few minutes and track crews went to work drying the speedway. The extra heavy humidity caused it to take over an hour to dry the surface, but all of the features except two were run. The scheduled SSCS Modified event was not going to be run as most of the drivers opted not to take the chance to travel to the track because of the bad forecast. The Mini Cup drivers in attendance opted not to run their feature because of unsafe conditions regarding a very wet infield which could have played havoc with the small cars had they gotten into the soaked infield area. The Legend Cars, Q mini Stocks, Scramblers and Figure-8s were able to race and put on a good show for the dampened crowd. Taylor" />
<meta name="twitter:image" content="http://karnac.com/flanews/wp-content/uploads/2017/10/Chris-Narramore-Sr.-honored-his-late-friend-Randy-King-with-a-victory-in-the-Q-Mini-Stocks.._-002-840x840.jpg" />
<meta itemprop="image" content="http://karnac.com/flanews/wp-content/uploads/2017/10/Chris-Narramore-Sr.-honored-his-late-friend-Randy-King-with-a-victory-in-the-Q-Mini-Stocks.._-002-840x840.jpg" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Karnac Racing News &raquo; Feed" href="http://karnac.com/flanews/feed/" />
<link rel="alternate" type="application/rss+xml" title="Karnac Racing News &raquo; Comments Feed" href="http://karnac.com/flanews/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/karnac.com\/flanews\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='jquery-bxslider-css'  href='http://karnac.com/flanews/wp-content/themes/supermag/assets/library/bxslider/css/jquery.bxslider.min.css?ver=4.2.5' type='text/css' media='all' />
<link rel='stylesheet' id='supermag-googleapis-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A600%2C400%7CRoboto%3A300italic%2C400%2C500%2C700&#038;ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='http://karnac.com/flanews/wp-content/themes/supermag/assets/library/Font-Awesome/css/font-awesome.min.css?ver=4.5.0' type='text/css' media='all' />
<link rel='stylesheet' id='supermag-style-css'  href='http://karnac.com/flanews/wp-content/themes/supermag/style.css?ver=1.4.9' type='text/css' media='all' />
<style id='supermag-style-inline-css' type='text/css'>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</style>
<!-- Inline jetpack_facebook_likebox -->
<style id='jetpack_facebook_likebox-inline-css' type='text/css'>
.widget_facebook_likebox {
	overflow: hidden;
}

</style>
<link rel='stylesheet' id='social-logos-css'  href='http://karnac.com/flanews/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://karnac.com/flanews/wp-content/plugins/jetpack/css/jetpack.css?ver=5.1' type='text/css' media='all' />
<script type='text/javascript' src='http://karnac.com/flanews/wp-includes/js/swfobject.js?ver=2.2-20120417'></script>
<script type='text/javascript' src='http://karnac.com/flanews/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://karnac.com/flanews/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://karnac.com/flanews/wp-content/themes/supermag/assets/library/html5shiv/html5shiv.min.js?ver=3.7.3'></script>
<![endif]-->
<!--[if lt IE 9]>
<script type='text/javascript' src='http://karnac.com/flanews/wp-content/themes/supermag/assets/library/respond/respond.min.js?ver=1.1.2'></script>
<![endif]-->
<link rel='https://api.w.org/' href='http://karnac.com/flanews/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://karnac.com/flanews/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://karnac.com/flanews/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Southern All Stars Gear Up For Season Finale At Talladega Short Track' href='http://karnac.com/flanews/upcoming-events/southern-all-stars-gear-up-for-season-finale-at-talladega-short-track/' />
<meta name="generator" content="WordPress 4.8.2" />
<link rel='shortlink' href='http://wp.me/p3OZWm-6xF' />
<link rel="alternate" type="application/json+oembed" href="http://karnac.com/flanews/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fkarnac.com%2Fflanews%2Ftracks%2Fauburndale-speedway%2Fmother-nature-is-the-big-winner-again-at-auburndale-speedway-but-some-races-do-get-run%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://karnac.com/flanews/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fkarnac.com%2Fflanews%2Ftracks%2Fauburndale-speedway%2Fmother-nature-is-the-big-winner-again-at-auburndale-speedway-but-some-races-do-get-run%2F&#038;format=xml" />
		<script type="text/javascript">
            var _statcounter = _statcounter || [];
            _statcounter.push({"tags": {"author": "Scott"}});
        </script>
	   <link rel="stylesheet" href="http://karnac.com/flanews/wp-content/plugins/stream-video-player/responsive.css?ver=" type="text/css" media="all" /><script type="text/javascript">
<!--
/******************************************************************************
***   COPY PROTECTED BY http://chetangole.com/blog/wp-copyprotect/   version 3.1.0 ****
******************************************************************************/
var message="Quit Stealing my Stuff you Plagiarizing Thief";
function clickIE4(){
if (event.button==2){
alert(message);
return false;
}
}

function clickNS4(e){
if (document.layers||document.getElementById&&!document.all){
if (e.which==2||e.which==3){
alert(message);
return false;
}
}
}

if (document.layers){
document.captureEvents(Event.MOUSEDOWN);
document.onmousedown=clickNS4;
}
else if (document.all&&!document.getElementById){
document.onmousedown=clickIE4;
}
document.oncontextmenu=new Function("alert(message);return false")
// --> 
</script>

<script type="text/javascript">
/******************************************************************************
***   COPY PROTECTED BY http://chetangole.com/blog/wp-copyprotect/   version 3.1.0 ****
******************************************************************************/
function disableSelection(target){
if (typeof target.onselectstart!="undefined") //For IE 
	target.onselectstart=function(){return false}
else if (typeof target.style.MozUserSelect!="undefined") //For Firefox
	target.style.MozUserSelect="none"
else //All other route (For Opera)
	target.onmousedown=function(){return false}
target.style.cursor = "default"
}
</script>

<link rel='dns-prefetch' href='//v0.wordpress.com'>
<style type='text/css'>img#wpstats{display:none}</style><style type="text/css" id="custom-background-css">
body.custom-background { background-image: url("http://karnac.com/flanews/wp-content/uploads/2013/08/test7.jpg"); background-position: center center; background-size: contain; background-repeat: repeat; background-attachment: fixed; }
</style>
<link rel="icon" href="http://karnac.com/flanews/wp-content/uploads/2017/04/Karnac-Logo-4-500x187.png" sizes="32x32" />
<link rel="icon" href="http://karnac.com/flanews/wp-content/uploads/2017/04/Karnac-Logo-4-500x187.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://karnac.com/flanews/wp-content/uploads/2017/04/Karnac-Logo-4-500x187.png" />
<meta name="msapplication-TileImage" content="http://karnac.com/flanews/wp-content/uploads/2017/04/Karnac-Logo-4-500x187.png" />
			<style type="text/css" id="wp-custom-css">
				/*
	CSS Migrated from Jetpack:
*/
.site-info { display: none; }			</style>
		
	</head>
<body class="post-template-default single single-post postid-25151 single-format-standard custom-background boxed-layout supermag-enable-box-shadow blog-no-image single-large-image center-logo-below-ads right-sidebar at-sticky-sidebar group-blog">

        <div id="page" class="hfeed site">
        <a class="skip-link screen-reader-text" href="#content" title="link">Skip to content</a>
            <header id="masthead" class="site-header" role="banner">
            <div class="top-header-section clearfix">
                <div class="wrapper">
                     <div class="header-latest-posts float-left bn-title">Thursday, October 12, 2017</div>                            <div class="header-latest-posts bn-wrapper float-left">
                                <div class="bn-title">
                                    Recent posts                                </div>
                                <ul class="bn">
                                                                            <li class="bn-content">
                                            <a href="http://karnac.com/flanews/tracks/auburndale-speedway/mother-nature-is-the-big-winner-again-at-auburndale-speedway-but-some-races-do-get-run/" title="MOTHER NATURE IS THE BIG WINNER AGAIN AT AUBURNDALE SPEEDWAY BUT SOME RACES DO GET RUN">
                                                MOTHER NATURE IS THE BIG WINNER AGAIN AT AUBURNDALE SPEEDWAY BUT SOME RACES DO GET RUN                                            </a>
                                        </li>
                                                                            <li class="bn-content">
                                            <a href="http://karnac.com/flanews/upcoming-events/southern-all-stars-gear-up-for-season-finale-at-talladega-short-track/" title="Southern All Stars Gear Up For Season Finale At Talladega Short Track">
                                                Southern All Stars Gear Up For Season Finale At Talladega Short Track                                            </a>
                                        </li>
                                                                            <li class="bn-content">
                                            <a href="http://karnac.com/flanews/series/lucas-oil-late-model-dirt-series/don-oneal-paces-pittsburgher-field-for-20000-victory/" title="DON O’NEAL PACES PITTSBURGHER FIELD FOR $20,000 VICTORY">
                                                DON O’NEAL PACES PITTSBURGHER FIELD FOR $20,000 VICTORY                                            </a>
                                        </li>
                                                                            <li class="bn-content">
                                            <a href="http://karnac.com/flanews/tracks/east-bay-raceway-park/steve-mathis-jr-picks-up-very-first-feature-win-in-late-models-at-east-bay-raceway-park/" title="STEVE MATHIS, JR. PICKS UP VERY FIRST FEATURE WIN IN LATE MODELS AT EAST BAY RACEWAY PARK">
                                                STEVE MATHIS, JR. PICKS UP VERY FIRST FEATURE WIN IN LATE MODELS AT EAST BAY RACEWAY PARK                                            </a>
                                        </li>
                                                                            <li class="bn-content">
                                            <a href="http://karnac.com/flanews/racing-news/dirtcar-fall-nationals-kicks-off-after-battle-with-mother-nature/" title="DIRTcar Fall Nationals Kicks Off after Battle with Mother Nature">
                                                DIRTcar Fall Nationals Kicks Off after Battle with Mother Nature                                            </a>
                                        </li>
                                                                    </ul>
                            </div> <!-- .header-latest-posts -->
                                            <div class="right-header float-right">
                                            </div>
                </div>
            </div><!-- .top-header-section -->
            <div class="header-wrapper clearfix">
                <div class="header-container">
	                                    <div class="wrapper">
                        <div class="site-branding clearfix">
                                                            <div class="header-ads float-right">
                                    <aside id="text-105" class="widget widget_text">			<div class="textwidget"><script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'http://ads.1motorsport.com/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script>
<script type="text/javascript">
var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
var abkw = window.abkw || '';
var plc207499 = window.plc207499 || 0;
document.write('<'+'div id="placement_207499_'+plc207499+'"></'+'div>');
AdButler.ads.push({handler: function(opt){ AdButler.register(165890, 207499, [728,90], 'placement_207499_'+opt.place, opt); }, opt: { place: plc207499++, keywords: abkw, domain: 'ads.1motorsport.com', click:'CLICK_MACRO_PLACEHOLDER' }});
</script>
</div>
		</aside><aside id="text-42" class="widget widget_text">			<div class="textwidget"><div align="center"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 728x90, created 10/9/09 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-8957007654552288"
     data-ad-slot="1273103748"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside>                                </div>
                                                        <div class="clearfix"></div>
                        </div>
                    </div>
	                <div id="wp-custom-header" class="wp-custom-header"><div class="wrapper header-image-wrap"><a  href="http://karnac.com/flanews/" title="Karnac Racing News" rel="home"><img src="http://karnac.com/flanews/wp-content/uploads/2012/08/Karnac-Banner-copy4.png" width="726" height="107" alt="Karnac Racing News" /> </a></div></div>                    <nav id="site-navigation" class="main-navigation  clearfix" role="navigation">
                        <div class="header-main-menu wrapper clearfix">
                            <div class="acmethemes-nav"><ul id="menu-main-menu" class="menu"><li id="menu-item-12761" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-12761"><a href="http://karnac.com/flanews">Home</a></li>
<li id="menu-item-8643" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-8643"><a href="http://karnac.com/flanews/topics/tracks/">Tracks</a>
<ul  class="sub-menu">
	<li id="menu-item-22978" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22978"><a href="http://karnac.com/flanews/topics/tracks/all-tech-raceway/">All-Tech Raceway</a></li>
	<li id="menu-item-8645" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-8645"><a href="http://karnac.com/flanews/topics/tracks/auburndale-speedway/">Auburndale Speedway</a></li>
	<li id="menu-item-11929" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11929"><a href="http://karnac.com/flanews/topics/tracks/ocala-speedway/">Bubba Raceway Park</a></li>
	<li id="menu-item-8646" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8646"><a href="http://karnac.com/flanews/topics/tracks/citrus-county-speedway/">Citrus County Speedway</a></li>
	<li id="menu-item-8648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8648"><a href="http://karnac.com/flanews/topics/tracks/east-bay-raceway-park/">East Bay Raceway Park</a></li>
	<li id="menu-item-12217" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12217"><a href="http://karnac.com/flanews/topics/tracks/five-flags-speedway/">Five Flags Speedway</a></li>
	<li id="menu-item-17358" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17358"><a href="http://karnac.com/flanews/topics/tracks/full-throttle-speedway/">Desoto Speedway</a></li>
	<li id="menu-item-23947" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23947"><a href="http://karnac.com/flanews/topics/tracks/golden-isle-speedway/">Golden Isle Speedway</a></li>
	<li id="menu-item-13161" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13161"><a href="http://karnac.com/flanews/topics/tracks/new-smyrna-speedway/">New Smyrna Speedway</a></li>
	<li id="menu-item-22979" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22979"><a href="http://karnac.com/flanews/topics/tracks/north-florida-speedway/">North Florida Speedway</a></li>
	<li id="menu-item-13370" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13370"><a href="http://karnac.com/flanews/topics/tracks/orlando-speedworld/">Orlando Speedworld</a></li>
	<li id="menu-item-12399" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12399"><a href="http://karnac.com/flanews/topics/tracks/showtime-speedway/">Showtime Speedway</a></li>
	<li id="menu-item-22975" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22975"><a href="http://karnac.com/flanews/topics/tracks/volusia-speedway-park/">Volusia Speedway Park</a></li>
</ul>
</li>
<li id="menu-item-8199" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-8199"><a href="http://karnac.com/flanews/topics/series/">Series</a>
<ul  class="sub-menu">
	<li id="menu-item-12972" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12972"><a href="http://karnac.com/flanews/topics/series/arca/">ARCA</a>
	<ul  class="sub-menu">
		<li id="menu-item-12446" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12446"><a href="http://karnac.com/flanews/topics/series/cra-racing-series/">CRA Racing Series</a></li>
	</ul>
</li>
	<li id="menu-item-16032" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16032"><a href="http://karnac.com/flanews/topics/series/fastrak-late-model-series/">Fastrak Late Model Series</a></li>
	<li id="menu-item-13036" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13036"><a href="http://karnac.com/flanews/topics/series/imca/">IMCA</a></li>
	<li id="menu-item-12447" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12447"><a href="http://karnac.com/flanews/topics/series/lucas-oil-late-model-dirt-series/">Lucas Oil Late Model Dirt Series</a></li>
	<li id="menu-item-13487" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13487"><a href="http://karnac.com/flanews/topics/series/mars-dirtcar-series/">MARS DIRTcar Series</a></li>
	<li id="menu-item-12913" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12913"><a href="http://karnac.com/flanews/topics/series/nesmith-chevrolet-dirt-late-model-series/">NeSmith Chevrolet Dirt Late Model Series</a></li>
	<li id="menu-item-12504" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12504"><a href="http://karnac.com/flanews/topics/series/pro-all-stars-series/">Pro All Stars Series</a></li>
	<li id="menu-item-12924" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12924"><a href="http://karnac.com/flanews/topics/series/southern-all-stars/">Southern All Stars</a></li>
	<li id="menu-item-20552" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20552"><a href="http://karnac.com/flanews/topics/series/southern-super-series/">Southern Super Series</a></li>
	<li id="menu-item-8657" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8657"><a href="http://karnac.com/flanews/topics/series/top-gun-sprints/">Top Gun Sprints</a></li>
	<li id="menu-item-12491" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12491"><a href="http://karnac.com/flanews/topics/series/uara-stars/">UARA-STARS</a></li>
	<li id="menu-item-17503" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17503"><a href="http://karnac.com/flanews/topics/series/ultimate-super-late-model-seires/">ULTIMATE Super Late Model Seires</a></li>
	<li id="menu-item-24417" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24417"><a href="http://karnac.com/flanews/topics/series/usac-racing/">USAC Racing</a></li>
	<li id="menu-item-12515" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12515"><a href="http://karnac.com/flanews/topics/series/artic-cat-all-star-circuit-of-champions/">Artic Cat All Star Circuit of Champions</a></li>
	<li id="menu-item-12054" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-12054"><a href="http://karnac.com/flanews/topics/series/world-of-outlaws/">World of Outlaws</a>
	<ul  class="sub-menu">
		<li id="menu-item-12646" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12646"><a href="http://karnac.com/flanews/topics/series/world-of-outlaws/sprint-cars/">Sprint Cars</a></li>
		<li id="menu-item-12639" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12639"><a href="http://karnac.com/flanews/topics/series/world-of-outlaws/late-models/">Late Models</a></li>
		<li id="menu-item-23948" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23948"><a href="http://karnac.com/flanews/topics/series/world-of-outlaws/dirtcar-summer-nationals/">DIRTcar Racing</a></li>
		<li id="menu-item-12640" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12640"><a href="http://karnac.com/flanews/topics/series/world-of-outlaws/super-dirtcar-series/">Super DIRTcar Series</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-11923" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11923"><a href="http://karnac.com/flanews/topics/race-results/">Race Results</a></li>
<li id="menu-item-11925" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11925"><a href="http://karnac.com/flanews/topics/upcoming-events/">Upcoming Events</a></li>
<li id="menu-item-12068" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12068"><a href="http://karnac.com/flanews/topics/series/racing-news/">Racing News</a></li>
<li id="menu-item-11961" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11961"><a href="http://www.realracinusa.com/forums/">Message Board</a></li>
</ul></div>                        </div>
                        <div class="responsive-slick-menu clearfix"></div>
                    </nav>
                    <!-- #site-navigation -->
	                                </div>
                <!-- .header-container -->
            </div>
            <!-- header-wrapper-->
        </header>
        <!-- #masthead -->
            <div class="wrapper content-wrapper clearfix">
            <div id="content" class="site-content">
    	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
			
<article id="post-25151" class="post-25151 post type-post status-publish format-standard has-post-thumbnail hentry category-auburndale-speedway category-local category-racing-news">
	<header class="entry-header">
		<h1 class="entry-title">MOTHER NATURE IS THE BIG WINNER AGAIN AT AUBURNDALE SPEEDWAY BUT SOME RACES DO GET RUN</h1>
		<div class="entry-meta">
			<span class="posted-on"><a href="http://karnac.com/flanews/tracks/auburndale-speedway/mother-nature-is-the-big-winner-again-at-auburndale-speedway-but-some-races-do-get-run/" rel="bookmark"><i class="fa fa-calendar"></i><time class="entry-date published updated" datetime="2017-10-10T15:05:08+00:00">October 10, 2017</time></a></span><span class="byline"> <span class="author vcard"><a class="url fn n" href="http://karnac.com/flanews/author/scott/"><i class="fa fa-user"></i>Scott</a></span></span>		</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

	<!--post thumbnal options-->
			<div class="single-feat clearfix">
			<figure class="single-thumb single-thumb-full">
				<img width="1716" height="1078" src="http://karnac.com/flanews/wp-content/uploads/2017/10/Chris-Narramore-Sr.-honored-his-late-friend-Randy-King-with-a-victory-in-the-Q-Mini-Stocks.._-002.jpg" class="attachment-full size-full wp-post-image" alt="" srcset="http://karnac.com/flanews/wp-content/uploads/2017/10/Chris-Narramore-Sr.-honored-his-late-friend-Randy-King-with-a-victory-in-the-Q-Mini-Stocks.._-002.jpg 1716w, http://karnac.com/flanews/wp-content/uploads/2017/10/Chris-Narramore-Sr.-honored-his-late-friend-Randy-King-with-a-victory-in-the-Q-Mini-Stocks.._-002-768x482.jpg 768w" sizes="(max-width: 1716px) 100vw, 1716px" data-attachment-id="25152" data-permalink="http://karnac.com/flanews/tracks/auburndale-speedway/mother-nature-is-the-big-winner-again-at-auburndale-speedway-but-some-races-do-get-run/attachment/chris-narramore-sr-honored-his-late-friend-randy-king-with-a-victory-in-the-q-mini-stocks-_-002/" data-orig-file="http://karnac.com/flanews/wp-content/uploads/2017/10/Chris-Narramore-Sr.-honored-his-late-friend-Randy-King-with-a-victory-in-the-Q-Mini-Stocks.._-002.jpg" data-orig-size="1716,1078" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1507408905&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Chris Narramore Sr. honored his late friend Randy King with a victory in the Q Mini Stocks.._ (002)" data-image-description="" data-medium-file="http://karnac.com/flanews/wp-content/uploads/2017/10/Chris-Narramore-Sr.-honored-his-late-friend-Randy-King-with-a-victory-in-the-Q-Mini-Stocks.._-002-660x365.jpg" data-large-file="http://karnac.com/flanews/wp-content/uploads/2017/10/Chris-Narramore-Sr.-honored-his-late-friend-Randy-King-with-a-victory-in-the-Q-Mini-Stocks.._-002-840x840.jpg" />			</figure>
		</div><!-- .single-feat-->
		<div class="entry-content">
		<p>&#8220;I keep waiting for an ark to float by&#8221; were the words of Auburndale Speedway owner Rex Guy as, once again, rain canceled one full racing program and interrupted another this weekend.</p>
<p>Saturday night the heat races were just about completed when rain hit the speedway. However, the shower lasted just a few minutes and track crews went to work drying the speedway. The extra heavy humidity caused it to take over an hour to dry the surface, but all of the features except two were run. The scheduled SSCS Modified event was not going to be run as most of the drivers opted not to take the chance to travel to the track because of the bad forecast. The Mini Cup drivers in attendance opted not to run their feature because of unsafe conditions regarding a very wet infield which could have played havoc with the small cars had they gotten into the soaked infield area.<br />
The Legend Cars, Q mini Stocks, Scramblers and Figure-8s were able to race and put on a good show for the dampened crowd.</p>
<p>Taylor Hosford, making her very first start in a Legend Car at Auburndale, topped the heat race for the class but that put her near the rear of the feature starting line-up. Kyle Pitts grabbed the early lead and was soon challenged by teammate Seth Adams. Lap eight saw caution fly as a wheel came off the car of newcomer Booker Cothren.</p>
<p>Just after the restart, Adams surged to the point and would lead the rest of the way slowed only by a lap 12 yellow flag for a spin by Jim Smith in turn two and the stalled car of Travis Guard on the front stretch. Adams would go on to take the victory over Pitts and veteran Mike Verhaagh. Hosford would race her way to a solid fourth place as Smith rebounded from his spin to take fifth. Sixth went to Gavin Sexton trailed by Rusty Mallett, Cale Nolen, Guard and Cothren.</p>
<p>The Q Mini Stock drivers paid tribute to the late Randy King who a top racer at the track for several years. King&#8217;s number was 46 and several cars carried flags with the #46 on them. Chris Narramore, Sr. had a photo of King on the hood of his car as well while Donald Gatlin&#8217;s car was renumbered 46 in honor of King and carried his orange and black colors.</p>
<p>Gatlin zipped out to an early lead and looked to be well on his way of putting the special paint job in victory lane. However, as Gatlin&#8217;s engine began to lose power it was point leader Narramore grabbing the top spot on lap 15.<br />
Narramore streaked off to a very emotional win over Bruce Cozad and heat winner John Cummins, Jr. Colt Cecil was fourth while Gatlin held on to his fading machine for fifth ahead of Fred Martin. Matt Cummins was unable to start the feature.</p>
<p>Just three Scramblers showed up for action but they put on one heck of a great race. William Kerns led the opening 12 circuits before Keith Cantrill slipped by. Cantrill then held off repeated challenges from point leader Dustin Wilson to claim his second win of the season. Kerns would end up third claiming his tires were &#8220;tired.&#8221; Wilson won the heat race.</p>
<p>The Figure-8 cars rounded out the night of racing and it was local favorite Preston Davis scoring a dominating win by leading every lap. Joey Caterelli claimed the runner-up spot ahead of Wayne Calkins. Rounding out the finishers were Shane Grigsby, Seth Nistok, Sammy Cressman, Thomas Peel and Jared Meyer.</p>
<p>Sunday&#8217;s weather looked promising to start but a couple of brief showers set back the start of practice by over an hour. Despite some ominous looking clouds, cars kept streaming into the pits, well after the announced starting time of 4 pm.</p>
<p>Alas, it was not to be as a downpour hit the track just before 5 pm flooding the infield. All racing activity was canceled for the evening but the entire show has been rescheduled for next Sunday, October 15th, with racing starting at 4 pm. The Daytona Antique Automobile Racing Association (DAARA) will try once again to get a show in the books after now being rained out in consecutive weeks here as well as Saturday night at Citrus County Speedway.<br />
For information and updated schedules go to www.auburndalespeedway.net or the Auburndale Speedway Facebook page.</p>
<p>All photos are courtesy My Country Photos unless noted&#8230;</p>
<div style=""><div style="display:inline;"><a href="http://twitter.com/share?url=http%3A%2F%2Fkarnac.com%2Fflanews%2Ftracks%2Fauburndale-speedway%2Fmother-nature-is-the-big-winner-again-at-auburndale-speedway-but-some-races-do-get-run%2F" class="twitter-share-button" data-count="horizontal">Tweet</a><script type="text/javascript" src="http://platform.twitter.com/widgets.js"></script></div><div style="display:inline;"><iframe src="http://www.facebook.com/plugins/like.php?href=http%3A%2F%2Fkarnac.com%2Fflanews%2Ftracks%2Fauburndale-speedway%2Fmother-nature-is-the-big-winner-again-at-auburndale-speedway-but-some-races-do-get-run%2F&amp;send=false&amp;layout=button_count&amp;width=120&amp;show_faces=false&amp;action=like&amp;colorscheme=light&amp;font&amp;height=21" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:120px; height:21px;" allowTransparency="true"></iframe></div><div style="display:inline;"><g:plusone size="medium" href="http://karnac.com/flanews/tracks/auburndale-speedway/mother-nature-is-the-big-winner-again-at-auburndale-speedway-but-some-races-do-get-run/"></g:plusone><script type="text/javascript">(function() { var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true; po.src = 'https://apis.google.com/js/plusone.js'; var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s); })();</script></div></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><div class="fb-share-button" data-href="http://karnac.com/flanews/tracks/auburndale-speedway/mother-nature-is-the-big-winner-again-at-auburndale-speedway-but-some-races-do-get-run/" data-layout="button_count"></div></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://karnac.com/flanews/tracks/auburndale-speedway/mother-nature-is-the-big-winner-again-at-auburndale-speedway-but-some-races-do-get-run/" data-text="MOTHER NATURE IS THE BIG WINNER AGAIN AT AUBURNDALE SPEEDWAY BUT SOME RACES DO GET RUN"  >Tweet</a></li><li class="share-google-plus-1"><div class="googleplus1_button"><div class="g-plus" data-action="share" data-annotation="bubble" data-href="http://karnac.com/flanews/tracks/auburndale-speedway/mother-nature-is-the-big-winner-again-at-auburndale-speedway-but-some-races-do-get-run/"></div></div></li><li class="share-linkedin"><div class="linkedin_button"><script type="in/share" data-url="http://karnac.com/flanews/tracks/auburndale-speedway/mother-nature-is-the-big-winner-again-at-auburndale-speedway-but-some-races-do-get-run/" data-counter="right"></script></div></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button" href="http://karnac.com/flanews/tracks/auburndale-speedway/mother-nature-is-the-big-winner-again-at-auburndale-speedway-but-some-races-do-get-run/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-end"></li></ul></div></div></div>			</div><!-- .entry-content -->

	<footer class="entry-footer featured-desc">
		<span class="cat-links"><i class="fa fa-folder-o"></i><a href="http://karnac.com/flanews/topics/tracks/auburndale-speedway/" rel="category tag">Auburndale Speedway</a>, <a href="http://karnac.com/flanews/topics/local/" rel="category tag">Local</a>, <a href="http://karnac.com/flanews/topics/racing-news/" rel="category tag">Racing News</a></span>	</footer><!-- .entry-footer -->
</article><!-- #post-## -->


	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="http://karnac.com/flanews/upcoming-events/southern-all-stars-gear-up-for-season-finale-at-talladega-short-track/" rel="prev">Southern All Stars Gear Up For Season Finale At Talladega Short Track</a></div></div>
	</nav>                <h2 class="widget-title">
			        Related posts                </h2>
		                    <ul class="featured-entries-col featured-entries featured-col-posts featured-related-posts">
		                            <li class="acme-col-3">
                        <figure class="widget-image">
                            <a href="http://karnac.com/flanews/upcoming-events/southern-all-stars-gear-up-for-season-finale-at-talladega-short-track/">
						        <img width="621" height="840" src="http://karnac.com/flanews/wp-content/uploads/2017/10/22279737_1498460823554712_4834196979587288196_n-621x840.jpg" class="attachment-large size-large wp-post-image" alt="" data-attachment-id="25149" data-permalink="http://karnac.com/flanews/upcoming-events/southern-all-stars-gear-up-for-season-finale-at-talladega-short-track/attachment/22279737_1498460823554712_4834196979587288196_n/" data-orig-file="http://karnac.com/flanews/wp-content/uploads/2017/10/22279737_1498460823554712_4834196979587288196_n.jpg" data-orig-size="621,960" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="22279737_1498460823554712_4834196979587288196_n" data-image-description="" data-medium-file="http://karnac.com/flanews/wp-content/uploads/2017/10/22279737_1498460823554712_4834196979587288196_n-621x365.jpg" data-large-file="http://karnac.com/flanews/wp-content/uploads/2017/10/22279737_1498460823554712_4834196979587288196_n-621x840.jpg" />                            </a>
                        </figure>
                        <div class="featured-desc">
                            <div class="above-entry-meta">
						                                        <span>
                                    <a href="http://karnac.com/flanews/2017/10/10/">
                                        <i class="fa fa-calendar"></i>
	                                    October 10, 2017                                    </a>
                                </span>
                                <span>
                                    <a href="http://karnac.com/flanews/author/scott/" title="Scott">
                                        <i class="fa fa-user"></i>
	                                    Scott                                    </a>
                                </span>
                                <span>
                                    <span>Comments Off<span class="screen-reader-text"> on Southern All Stars Gear Up For Season Finale At Talladega Short Track</span></span>                                </span>
                            </div>
                            <a href="http://karnac.com/flanews/upcoming-events/southern-all-stars-gear-up-for-season-finale-at-talladega-short-track/">
                                <h4 class="title">
							        Southern All Stars Gear Up For Season Finale At Talladega Short Track                                </h4>
                            </a>
					        <div class="details">FAYETTEVILLE, TN- The Southern All Star Dirt Racing Series will conclude its 34th season of racing...</div>                            <div class="below-entry-meta">
						        <span class="cat-links"><a class="at-cat-item-73" href="http://karnac.com/flanews/topics/series/nesmith-chevrolet-dirt-late-model-series/"  rel="category tag">NeSmith Chevrolet Dirt Late Model Series</a>&nbsp;<a class="at-cat-item-61" href="http://karnac.com/flanews/topics/racing-news/"  rel="category tag">Racing News</a>&nbsp;<a class="at-cat-item-74" href="http://karnac.com/flanews/topics/series/southern-all-stars/"  rel="category tag">Southern All Stars</a>&nbsp;<a class="at-cat-item-21" href="http://karnac.com/flanews/topics/upcoming-events/"  rel="category tag">Upcoming Events</a>&nbsp;</span>                            </div>
                        </div>
                    </li>
			                            <li class="acme-col-3">
                        <figure class="widget-image">
                            <a href="http://karnac.com/flanews/series/lucas-oil-late-model-dirt-series/don-oneal-paces-pittsburgher-field-for-20000-victory/">
						        <img width="640" height="427" src="http://karnac.com/flanews/wp-content/uploads/2017/10/Don-ONeal-Wins-at-Pennsylvania-Speedway-2017.jpg" class="attachment-large size-large wp-post-image" alt="" data-attachment-id="25146" data-permalink="http://karnac.com/flanews/series/lucas-oil-late-model-dirt-series/don-oneal-paces-pittsburgher-field-for-20000-victory/attachment/neal-wins-at-pennsylvania-speedway-2017/" data-orig-file="http://karnac.com/flanews/wp-content/uploads/2017/10/Don-ONeal-Wins-at-Pennsylvania-Speedway-2017.jpg" data-orig-size="700,467" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="&#8216;Neal Wins at Pennsylvania Speedway 2017" data-image-description="" data-medium-file="http://karnac.com/flanews/wp-content/uploads/2017/10/Don-ONeal-Wins-at-Pennsylvania-Speedway-2017-660x365.jpg" data-large-file="http://karnac.com/flanews/wp-content/uploads/2017/10/Don-ONeal-Wins-at-Pennsylvania-Speedway-2017.jpg" />                            </a>
                        </figure>
                        <div class="featured-desc">
                            <div class="above-entry-meta">
						                                        <span>
                                    <a href="http://karnac.com/flanews/2017/10/08/">
                                        <i class="fa fa-calendar"></i>
	                                    October 8, 2017                                    </a>
                                </span>
                                <span>
                                    <a href="http://karnac.com/flanews/author/scott/" title="Scott">
                                        <i class="fa fa-user"></i>
	                                    Scott                                    </a>
                                </span>
                                <span>
                                    <span>Comments Off<span class="screen-reader-text"> on DON O’NEAL PACES PITTSBURGHER FIELD FOR $20,000 VICTORY</span></span>                                </span>
                            </div>
                            <a href="http://karnac.com/flanews/series/lucas-oil-late-model-dirt-series/don-oneal-paces-pittsburgher-field-for-20000-victory/">
                                <h4 class="title">
							        DON O’NEAL PACES PITTSBURGHER FIELD FOR $20,000 VICTORY                                </h4>
                            </a>
					        <div class="details">IMPERIAL, PA (October 7, 2017) Don O’Neal completed a weekend sweep, winning the 29th Annual Pittsburgher...</div>                            <div class="below-entry-meta">
						        <span class="cat-links"><a class="at-cat-item-59" href="http://karnac.com/flanews/topics/series/lucas-oil-late-model-dirt-series/"  rel="category tag">Lucas Oil Late Model Dirt Series</a>&nbsp;<a class="at-cat-item-117" href="http://karnac.com/flanews/topics/national/"  rel="category tag">National</a>&nbsp;<a class="at-cat-item-61" href="http://karnac.com/flanews/topics/racing-news/"  rel="category tag">Racing News</a>&nbsp;</span>                            </div>
                        </div>
                    </li>
			                            <li class="acme-col-3">
                        <figure class="widget-image">
                            <a href="http://karnac.com/flanews/tracks/east-bay-raceway-park/steve-mathis-jr-picks-up-very-first-feature-win-in-late-models-at-east-bay-raceway-park/">
						        <img width="620" height="400" src="http://karnac.com/flanews/wp-content/uploads/2017/10/10-7-17-Winner-620x400.jpg" class="attachment-large size-large wp-post-image" alt="" data-attachment-id="25143" data-permalink="http://karnac.com/flanews/tracks/east-bay-raceway-park/steve-mathis-jr-picks-up-very-first-feature-win-in-late-models-at-east-bay-raceway-park/attachment/10-7-17-winner-620x400/" data-orig-file="http://karnac.com/flanews/wp-content/uploads/2017/10/10-7-17-Winner-620x400.jpg" data-orig-size="620,400" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1507443445&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="10-7-17-Winner-620&#215;400" data-image-description="" data-medium-file="http://karnac.com/flanews/wp-content/uploads/2017/10/10-7-17-Winner-620x400-620x365.jpg" data-large-file="http://karnac.com/flanews/wp-content/uploads/2017/10/10-7-17-Winner-620x400.jpg" />                            </a>
                        </figure>
                        <div class="featured-desc">
                            <div class="above-entry-meta">
						                                        <span>
                                    <a href="http://karnac.com/flanews/2017/10/08/">
                                        <i class="fa fa-calendar"></i>
	                                    October 8, 2017                                    </a>
                                </span>
                                <span>
                                    <a href="http://karnac.com/flanews/author/scott/" title="Scott">
                                        <i class="fa fa-user"></i>
	                                    Scott                                    </a>
                                </span>
                                <span>
                                    <span>Comments Off<span class="screen-reader-text"> on STEVE MATHIS, JR. PICKS UP VERY FIRST FEATURE WIN IN LATE MODELS AT EAST BAY RACEWAY PARK</span></span>                                </span>
                            </div>
                            <a href="http://karnac.com/flanews/tracks/east-bay-raceway-park/steve-mathis-jr-picks-up-very-first-feature-win-in-late-models-at-east-bay-raceway-park/">
                                <h4 class="title">
							        STEVE MATHIS, JR. PICKS UP VERY FIRST FEATURE WIN IN LATE MODELS AT EAST BAY RACEWAY PARK                                </h4>
                            </a>
					        <div class="details">GIBSONTON — At East Bay Raceway it was Jim Baker winning in the Hobby Stocks, Brian...</div>                            <div class="below-entry-meta">
						        <span class="cat-links"><a class="at-cat-item-12" href="http://karnac.com/flanews/topics/tracks/east-bay-raceway-park/"  rel="category tag">East Bay Raceway Park</a>&nbsp;<a class="at-cat-item-115" href="http://karnac.com/flanews/topics/local/"  rel="category tag">Local</a>&nbsp;<a class="at-cat-item-61" href="http://karnac.com/flanews/topics/racing-news/"  rel="category tag">Racing News</a>&nbsp;</span>                            </div>
                        </div>
                    </li>
			                    </ul>
            <div class="clearfix"></div>
	        
		</main><!-- #main -->
	</div><!-- #primary -->
	<div id="secondary-right" class="widget-area sidebar secondary-sidebar float-right" role="complementary">
		<div id="sidebar-section-top" class="widget-area sidebar clearfix">
					<aside id="recent-posts-5" class="widget widget_recent_entries">		<h3 class="widget-title"><span>Recent Posts</span></h3>		<ul>
					<li>
				<a href="http://karnac.com/flanews/tracks/auburndale-speedway/mother-nature-is-the-big-winner-again-at-auburndale-speedway-but-some-races-do-get-run/">MOTHER NATURE IS THE BIG WINNER AGAIN AT AUBURNDALE SPEEDWAY BUT SOME RACES DO GET RUN</a>
						</li>
					<li>
				<a href="http://karnac.com/flanews/upcoming-events/southern-all-stars-gear-up-for-season-finale-at-talladega-short-track/">Southern All Stars Gear Up For Season Finale At Talladega Short Track</a>
						</li>
					<li>
				<a href="http://karnac.com/flanews/series/lucas-oil-late-model-dirt-series/don-oneal-paces-pittsburgher-field-for-20000-victory/">DON O’NEAL PACES PITTSBURGHER FIELD FOR $20,000 VICTORY</a>
						</li>
					<li>
				<a href="http://karnac.com/flanews/tracks/east-bay-raceway-park/steve-mathis-jr-picks-up-very-first-feature-win-in-late-models-at-east-bay-raceway-park/">STEVE MATHIS, JR. PICKS UP VERY FIRST FEATURE WIN IN LATE MODELS AT EAST BAY RACEWAY PARK</a>
						</li>
					<li>
				<a href="http://karnac.com/flanews/racing-news/dirtcar-fall-nationals-kicks-off-after-battle-with-mother-nature/">DIRTcar Fall Nationals Kicks Off after Battle with Mother Nature</a>
						</li>
					<li>
				<a href="http://karnac.com/flanews/upcoming-events/must-see-racing-sprints-must-see-sprints-added-to-megameltdown-at-hickory/">Must See Racing Sprints Must See Sprints Added to MegaMeltdown at Hickory</a>
						</li>
					<li>
				<a href="http://karnac.com/flanews/series/lucas-oil-late-model-dirt-series/don-oneal-and-mike-marlar-on-front-row-for-pittsburgher-100/">Don O&#8217;Neal and Mike Marlar on Front Row for Pittsburgher 100</a>
						</li>
					<li>
				<a href="http://karnac.com/flanews/racing-news/jegscra-all-stars-tour-ready-to-close-out-the-2017-season-at-winchester-speedway-friday/">JEGS/CRA All-Stars Tour Ready to Close out the 2017 Season at Winchester Speedway Friday</a>
						</li>
					<li>
				<a href="http://karnac.com/flanews/series/lucas-oil-late-model-dirt-series/darrell-lanigan-dominates-rome-showdown/">Darrell Lanigan Dominates Rome Showdown</a>
						</li>
					<li>
				<a href="http://karnac.com/flanews/series/lucas-oil-late-model-dirt-series/michael-page-claims-first-career-lucas-oil-victory/">Michael Page Claims First-Career Lucas Oil Victory!</a>
						</li>
				</ul>
		</aside>		<aside id="text-114" class="widget widget_text">			<div class="textwidget"><!-- Karnac.com 300x600 [async] -->
<script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'http://ads.1motorsport.com/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script>
<script type="text/javascript">
var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
var abkw = window.abkw || '';
var plc207498 = window.plc207498 || 0;
document.write('<'+'div id="placement_207498_'+plc207498+'"></'+'div>');
AdButler.ads.push({handler: function(opt){ AdButler.register(165890, 207498, [300,600], 'placement_207498_'+opt.place, opt); }, opt: { place: plc207498++, keywords: abkw, domain: 'ads.1motorsport.com', click:'CLICK_MACRO_PLACEHOLDER' }});
</script></div>
		</aside><aside id="text-113" class="widget widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 300x250 Tower Ad -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-8957007654552288"
     data-ad-slot="7505581171"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside><aside id="facebook-likebox-4" class="widget widget_facebook_likebox">		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/karnacracing/" data-width="350"  data-height="580" data-hide-cover="false" data-show-facepile="true" data-show-posts="true">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/karnacracing/"><a href="https://www.facebook.com/karnacracing/"></a></blockquote></div>
		</div>
		</aside>		</div>
	</div>
        </div><!-- #content -->
        </div><!-- content-wrapper-->
            <div class="clearfix"></div>
        <footer id="colophon" class="site-footer" role="contentinfo">
            <div class="footer-wrapper">
                <div class="top-bottom wrapper">
                    <div id="footer-top">
                        <div class="footer-columns">
                                                   </div>
                    </div><!-- #foter-top -->
                    <div class="clearfix"></div>
                 </div><!-- top-bottom-->
                <div class="wrapper footer-copyright border text-center">
                    <p>
                                                    Copyright &copy; All rights reserved                                            </p>
                    <div class="site-info">
                    <a href="https://wordpress.org/">Proudly powered by WordPress</a>
                    <span class="sep"> | </span>
                    Theme: SuperMag by <a href="https://www.acmethemes.com/" rel="designer">Acme Themes</a>.                    </div><!-- .site-info -->
                </div>
            </div><!-- footer-wrapper-->
        </footer><!-- #colophon -->
            </div><!-- #page -->
    <script language="javascript" type="text/javascript">var kpg_cell="N";var kpg_nrci_image="http://karnac.com/flanews/wp-content/plugins/no-right-click-images-plugin/not.gif";var kpg_nrci_extra="Y";var kpg_nrci_drag="Y";</script>
<script language="javascript" type="text/javascript" src="http://karnac.com/flanews/wp-content/plugins/no-right-click-images-plugin/no-right-click-images.js"></script>

    <!-- Start of StatCounter Code -->
    <script>
    <!-- 
        var sc_project=9187603; 
        var sc_security="c4c5fbcb"; 
        var scJsHost = (("https:" == document.location.protocol) ?
        "https://secure." : "http://www.");
    //-->
document.write("<sc"+"ript src='" +scJsHost +"statcounter.com/counter/counter.js'></"+"script>");
</script>
<noscript><div class="statcounter"><a title="web analytics" href="https://statcounter.com/"><img class="statcounter" src="https://c.statcounter.com/9187603/0/c4c5fbcb/0/" alt="web analytics" /></a></div></noscript>   
    <!-- End of StatCounter Code -->
<script type="text/javascript">
disableSelection(document.body)
</script>
<small>Copy Protected by <a href="http://chetangole.com/" target="_blank">Chetan</a>'s <a href="http://chetangole.com/blog/wp-copyprotect/" target="_blank">WP-Copyprotect</a>.</small>
	<div style="display:none">
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/karnac.com\/flanews\/tracks\/auburndale-speedway\/mother-nature-is-the-big-winner-again-at-auburndale-speedway-but-some-races-do-get-run\/":25151};
	</script>
<div id="fb-root"></div>
			<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
			<script>
			jQuery( document.body ).on( 'post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
						<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
						<script>
			function renderGooglePlus1() {
				if ( 'undefined' === typeof gapi ) {
					return;
				}

				jQuery( '.g-plus' ).each(function() {
					var $button = jQuery( this );

					if ( ! $button.data( 'gplus-rendered' ) ) {
						gapi.plusone.render( this, {
							href: $button.attr( 'data-href' ),
							size: $button.attr( 'data-size' ),
							annotation: $button.attr( 'data-annotation' )
						});

						$button.data( 'gplus-rendered', true );
					}
				});
			}

			(function() {
				var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
				po.src = 'https://apis.google.com/js/plusone.js';
				po.innerHTML = '{"parsetags": "explicit"}';
				po.onload = renderGooglePlus1;
				var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
			})();

			jQuery( document.body ).on( 'post-load', renderGooglePlus1 );
			</script>
			<script type="text/javascript">
			jQuery( document ).ready( function() {
				jQuery.getScript( 'https://platform.linkedin.com/in.js?async=true', function success() {
					IN.init();
				});
			});
			jQuery( document.body ).on( 'post-load', function() {
				if ( typeof IN != 'undefined' )
					IN.parse();
			});
			</script>	<div id="sharing_email" style="display: none;">
		<form action="/flanews/tracks/auburndale-speedway/mother-nature-is-the-big-winner-again-at-auburndale-speedway-but-some-races-do-get-run/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
			
			<img style="float: right; display: none" class="loading" src="http://karnac.com/flanews/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201741'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Octaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://karnac.com/flanews/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.8.2'></script>
<script type='text/javascript' src='http://karnac.com/flanews/wp-content/themes/supermag/assets/library/bxslider/js/jquery.bxslider.min.js?ver=4.2.5'></script>
<script type='text/javascript' src='http://karnac.com/flanews/wp-content/themes/supermag/assets/library/theia-sticky-sidebar/theia-sticky-sidebar.js?ver=1.4.0'></script>
<script type='text/javascript' src='http://karnac.com/flanews/wp-content/themes/supermag/assets/js/supermag-custom.js?ver=1.4.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='http://karnac.com/flanews/wp-content/plugins/jetpack/_inc/facebook-embed.js'></script>
<script type='text/javascript' src='http://karnac.com/flanews/wp-includes/js/wp-embed.min.js?ver=4.8.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://karnac.com/flanews/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=5.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201741.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.1',blog:'56483510',post:'25151',tz:'0',srv:'karnac.com'} ]);
	_stq.push([ 'clickTrackerInit', '56483510', '25151' ]);
</script>
</body>
</html>
<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Page Caching using disk: enhanced

 Served from: karnac.com @ 2017-10-12 11:19:01 by W3 Total Cache -->