        <!DOCTYPE html><html lang="en-US"
	itemscope 
	itemtype="http://schema.org/Article" 
	prefix="og: http://ogp.me/ns#" >
    	<head>

		        <meta charset="UTF-8">
        <meta name="viewport" content="width=device-width, initial-scale=1">
        <link rel="profile" href="http://gmpg.org/xfn/11">
        <link rel="pingback" href="http://karnac.com/flanews/xmlrpc.php">
    <title>AUBURNDALE SPEEDWAY KICKS OFF 2018 SEASON WITH 75 LAPS OF PRO TRUCK RACING SATURDAY NIGHT | Karnac Racing News</title>

<!-- All in One SEO Pack 2.3.4.2 by Michael Torbert of Semper Fi Web Design[387,510] -->
<link rel="author" href="http://scott" />

<link rel="canonical" href="http://karnac.com/flanews/tracks/auburndale-speedway/auburndale-speedway-kicks-off-2018-season-with-75-laps-of-pro-truck-racing-saturday-night/" />
<meta property="og:title" content="AUBURNDALE SPEEDWAY KICKS OFF 2018 SEASON WITH 75 LAPS OF PRO TRUCK RACING SATURDAY NIGHT | Karnac Racing News" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://karnac.com/flanews/tracks/auburndale-speedway/auburndale-speedway-kicks-off-2018-season-with-75-laps-of-pro-truck-racing-saturday-night/" />
<meta property="og:image" content="http://karnac.com/flanews/wp-content/uploads/2018/01/2018-Season-Opener-840x786.jpg" />
<meta property="og:site_name" content="Karnac Racing News" />
<meta property="fb:admins" content="scott@karnac.com" />
<meta property="fb:app_id" content="1477858575609869" />
<meta property="og:description" content="Auburndale Speedway Gets the 2018 racing season under way in a big way this Saturday night with the Super Bowl 75 for the Pro Trucks headlining the racing card. Also in action will be the Legend Cars, V-8 Bombers, Q Mini Stocks, Mini Cup cars and the Scramblers. Among the Pro Truck drivers expected are Rodney and Blake Haddock from Hilliard who will be making their first start here in some time, Derek Pugh of Crystal River, Palmetto&#039;s Jason Lester, Auburndale drivers William Kerns and Colt Cecil, Tyler Davis and Cody McDuffie of Lakeland, Pinellas Park&#039;s Devin Kyle, Mike Kohut of Lehigh Acres and several more. This 75-lap event pays a cool $1300 to win plus a $75 bonus for the fast qualifier. The event is the first of 11 total for the Pro Trucks in 2018. All others will be 50 laps in length with the exception of September 22nd when the Pro Trucks will run twin 25-lap races. Pit gates open at 3 pm with practice slated from 4-5:30 pm. Grandstand gates open at 5 pm and qualifying for the" />
<meta property="article:tag" content="auburndale speedway" />
<meta property="article:tag" content="racing news" />
<meta property="article:tag" content="upcoming events" />
<meta property="article:published_time" content="2018-01-24T16:59:56Z" />
<meta property="article:modified_time" content="2018-01-24T16:59:56Z" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:title" content="AUBURNDALE SPEEDWAY KICKS OFF 2018 SEASON WITH 75 LAPS OF PRO TRUCK RACING SATURDAY NIGHT | Karnac Racing News" />
<meta name="twitter:description" content="Auburndale Speedway Gets the 2018 racing season under way in a big way this Saturday night with the Super Bowl 75 for the Pro Trucks headlining the racing card. Also in action will be the Legend Cars, V-8 Bombers, Q Mini Stocks, Mini Cup cars and the Scramblers. Among the Pro Truck drivers expected are Rodney and Blake Haddock from Hilliard who will be making their first start here in some time, Derek Pugh of Crystal River, Palmetto&#039;s Jason Lester, Auburndale drivers William Kerns and Colt Cecil, Tyler Davis and Cody McDuffie of Lakeland, Pinellas Park&#039;s Devin Kyle, Mike Kohut of Lehigh Acres and several more. This 75-lap event pays a cool $1300 to win plus a $75 bonus for the fast qualifier. The event is the first of 11 total for the Pro Trucks in 2018. All others will be 50 laps in length with the exception of September 22nd when the Pro Trucks will run twin 25-lap races. Pit gates open at 3 pm with practice slated from 4-5:30 pm. Grandstand gates open at 5 pm and qualifying for the" />
<meta name="twitter:image" content="http://karnac.com/flanews/wp-content/uploads/2018/01/2018-Season-Opener-840x786.jpg" />
<meta itemprop="image" content="http://karnac.com/flanews/wp-content/uploads/2018/01/2018-Season-Opener-840x786.jpg" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Karnac Racing News &raquo; Feed" href="http://karnac.com/flanews/feed/" />
<link rel="alternate" type="application/rss+xml" title="Karnac Racing News &raquo; Comments Feed" href="http://karnac.com/flanews/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/karnac.com\/flanews\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.5"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='jquery-bxslider-css'  href='http://karnac.com/flanews/wp-content/themes/supermag/assets/library/bxslider/css/jquery.bxslider.min.css?ver=4.2.5' type='text/css' media='all' />
<link rel='stylesheet' id='supermag-googleapis-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A600%2C400%7CRoboto%3A300italic%2C400%2C500%2C700&#038;ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='http://karnac.com/flanews/wp-content/themes/supermag/assets/library/Font-Awesome/css/font-awesome.min.css?ver=4.5.0' type='text/css' media='all' />
<link rel='stylesheet' id='supermag-style-css'  href='http://karnac.com/flanews/wp-content/themes/supermag/style.css?ver=1.4.9' type='text/css' media='all' />
<style id='supermag-style-inline-css' type='text/css'>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</style>
<!-- Inline jetpack_facebook_likebox -->
<style id='jetpack_facebook_likebox-inline-css' type='text/css'>
.widget_facebook_likebox {
	overflow: hidden;
}

</style>
<link rel='stylesheet' id='social-logos-css'  href='http://karnac.com/flanews/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://karnac.com/flanews/wp-content/plugins/jetpack/css/jetpack.css?ver=5.1' type='text/css' media='all' />
<script type='text/javascript' src='http://karnac.com/flanews/wp-includes/js/swfobject.js?ver=2.2-20120417'></script>
<script type='text/javascript' src='http://karnac.com/flanews/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://karnac.com/flanews/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://karnac.com/flanews/wp-content/themes/supermag/assets/library/html5shiv/html5shiv.min.js?ver=3.7.3'></script>
<![endif]-->
<!--[if lt IE 9]>
<script type='text/javascript' src='http://karnac.com/flanews/wp-content/themes/supermag/assets/library/respond/respond.min.js?ver=1.1.2'></script>
<![endif]-->
<link rel='https://api.w.org/' href='http://karnac.com/flanews/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://karnac.com/flanews/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://karnac.com/flanews/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Volusia Speedway Park Gets a $300,000 Safety Upgrade for DIRTcar Nationals' href='http://karnac.com/flanews/upcoming-events/volusia-speedway-park-gets-a-300000-safety-upgrade-for-dirtcar-nationals/' />
<meta name="generator" content="WordPress 4.8.5" />
<link rel='shortlink' href='http://wp.me/p3OZWm-6A6' />
<link rel="alternate" type="application/json+oembed" href="http://karnac.com/flanews/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fkarnac.com%2Fflanews%2Ftracks%2Fauburndale-speedway%2Fauburndale-speedway-kicks-off-2018-season-with-75-laps-of-pro-truck-racing-saturday-night%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://karnac.com/flanews/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fkarnac.com%2Fflanews%2Ftracks%2Fauburndale-speedway%2Fauburndale-speedway-kicks-off-2018-season-with-75-laps-of-pro-truck-racing-saturday-night%2F&#038;format=xml" />
		<script type="text/javascript">
            var _statcounter = _statcounter || [];
            _statcounter.push({"tags": {"author": "Scott"}});
        </script>
	   <link rel="stylesheet" href="http://karnac.com/flanews/wp-content/plugins/stream-video-player/responsive.css?ver=" type="text/css" media="all" /><script type="text/javascript">
<!--
/******************************************************************************
***   COPY PROTECTED BY http://chetangole.com/blog/wp-copyprotect/   version 3.1.0 ****
******************************************************************************/
var message="Quit Stealing my Stuff you Plagiarizing Thief";
function clickIE4(){
if (event.button==2){
alert(message);
return false;
}
}

function clickNS4(e){
if (document.layers||document.getElementById&&!document.all){
if (e.which==2||e.which==3){
alert(message);
return false;
}
}
}

if (document.layers){
document.captureEvents(Event.MOUSEDOWN);
document.onmousedown=clickNS4;
}
else if (document.all&&!document.getElementById){
document.onmousedown=clickIE4;
}
document.oncontextmenu=new Function("alert(message);return false")
// --> 
</script>

<script type="text/javascript">
/******************************************************************************
***   COPY PROTECTED BY http://chetangole.com/blog/wp-copyprotect/   version 3.1.0 ****
******************************************************************************/
function disableSelection(target){
if (typeof target.onselectstart!="undefined") //For IE 
	target.onselectstart=function(){return false}
else if (typeof target.style.MozUserSelect!="undefined") //For Firefox
	target.style.MozUserSelect="none"
else //All other route (For Opera)
	target.onmousedown=function(){return false}
target.style.cursor = "default"
}
</script>

<link rel='dns-prefetch' href='//v0.wordpress.com'>
<style type='text/css'>img#wpstats{display:none}</style><style type="text/css" id="custom-background-css">
body.custom-background { background-image: url("http://karnac.com/flanews/wp-content/uploads/2018/01/4ad000975d359c7dd60c17b573fb327f.jpg"); background-position: left top; background-size: cover; background-repeat: no-repeat; background-attachment: fixed; }
</style>
<link rel="icon" href="http://karnac.com/flanews/wp-content/uploads/2017/04/Karnac-Logo-4-500x187.png" sizes="32x32" />
<link rel="icon" href="http://karnac.com/flanews/wp-content/uploads/2017/04/Karnac-Logo-4-500x187.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://karnac.com/flanews/wp-content/uploads/2017/04/Karnac-Logo-4-500x187.png" />
<meta name="msapplication-TileImage" content="http://karnac.com/flanews/wp-content/uploads/2017/04/Karnac-Logo-4-500x187.png" />
			<style type="text/css" id="wp-custom-css">
				/*
	CSS Migrated from Jetpack:
*/
.site-info { display: none; }			</style>
		
	</head>
<body class="post-template-default single single-post postid-25302 single-format-standard custom-background boxed-layout supermag-enable-box-shadow blog-no-image single-large-image center-logo-below-ads right-sidebar at-sticky-sidebar group-blog">

        <div id="page" class="hfeed site">
        <a class="skip-link screen-reader-text" href="#content" title="link">Skip to content</a>
            <header id="masthead" class="site-header" role="banner">
            <div class="top-header-section clearfix">
                <div class="wrapper">
                     <div class="header-latest-posts float-left bn-title">Wednesday, January 24, 2018</div>                            <div class="header-latest-posts bn-wrapper float-left">
                                <div class="bn-title">
                                    Recent posts                                </div>
                                <ul class="bn">
                                                                            <li class="bn-content">
                                            <a href="http://karnac.com/flanews/tracks/auburndale-speedway/auburndale-speedway-kicks-off-2018-season-with-75-laps-of-pro-truck-racing-saturday-night/" title="AUBURNDALE SPEEDWAY KICKS OFF 2018 SEASON WITH 75 LAPS OF PRO TRUCK RACING SATURDAY NIGHT">
                                                AUBURNDALE SPEEDWAY KICKS OFF 2018 SEASON WITH 75 LAPS OF PRO TRUCK RACING SATURDAY NIGHT                                            </a>
                                        </li>
                                                                            <li class="bn-content">
                                            <a href="http://karnac.com/flanews/upcoming-events/volusia-speedway-park-gets-a-300000-safety-upgrade-for-dirtcar-nationals/" title="Volusia Speedway Park Gets a $300,000 Safety Upgrade for DIRTcar Nationals">
                                                Volusia Speedway Park Gets a $300,000 Safety Upgrade for DIRTcar Nationals                                            </a>
                                        </li>
                                                                            <li class="bn-content">
                                            <a href="http://karnac.com/flanews/racing-news/cars-tour-to-host-and-sanction-two-limited-late-model-races-in-2018/" title="CARS Tour to Host and Sanction Two Limited Late Model Races in 2018">
                                                CARS Tour to Host and Sanction Two Limited Late Model Races in 2018                                            </a>
                                        </li>
                                                                            <li class="bn-content">
                                            <a href="http://karnac.com/flanews/upcoming-events/pass-super-late-models-to-headline-inaugural-commonwealth-classic-at-richmond-raceway/" title="PASS Super Late Models  To Headline Inaugural  Commonwealth Classic  At Richmond Raceway">
                                                PASS Super Late Models  To Headline Inaugural  Commonwealth Classic  At Richmond Raceway                                            </a>
                                        </li>
                                                                            <li class="bn-content">
                                            <a href="http://karnac.com/flanews/upcoming-events/weather-forecast-results-in-major-cra-speedfest-2018-schedule-changes/" title="Weather Forecast Results in Major CRA SpeedFest 2018 Schedule Changes">
                                                Weather Forecast Results in Major CRA SpeedFest 2018 Schedule Changes                                            </a>
                                        </li>
                                                                    </ul>
                            </div> <!-- .header-latest-posts -->
                                            <div class="right-header float-right">
                                            </div>
                </div>
            </div><!-- .top-header-section -->
            <div class="header-wrapper clearfix">
                <div class="header-container">
	                                    <div class="wrapper">
                        <div class="site-branding clearfix">
                                                            <div class="header-ads float-right">
                                    <aside id="text-105" class="widget widget_text">			<div class="textwidget"><script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'http://ads.1motorsport.com/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script>
<script type="text/javascript">
var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
var abkw = window.abkw || '';
var plc207499 = window.plc207499 || 0;
document.write('<'+'div id="placement_207499_'+plc207499+'"></'+'div>');
AdButler.ads.push({handler: function(opt){ AdButler.register(165890, 207499, [728,90], 'placement_207499_'+opt.place, opt); }, opt: { place: plc207499++, keywords: abkw, domain: 'ads.1motorsport.com', click:'CLICK_MACRO_PLACEHOLDER' }});
</script>
</div>
		</aside><aside id="text-42" class="widget widget_text">			<div class="textwidget"><div align="center"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 728x90, created 10/9/09 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-8957007654552288"
     data-ad-slot="1273103748"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside>                                </div>
                                                        <div class="clearfix"></div>
                        </div>
                    </div>
	                <div id="wp-custom-header" class="wp-custom-header"><div class="wrapper header-image-wrap"><a  href="http://karnac.com/flanews/" title="Karnac Racing News" rel="home"><img src="http://karnac.com/flanews/wp-content/uploads/2012/08/Karnac-Banner-copy4.png" width="726" height="107" alt="Karnac Racing News" /> </a></div></div>                    <nav id="site-navigation" class="main-navigation  clearfix" role="navigation">
                        <div class="header-main-menu wrapper clearfix">
                            <div class="acmethemes-nav"><ul id="menu-main-menu" class="menu"><li id="menu-item-12761" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-12761"><a href="http://karnac.com/flanews">Home</a></li>
<li id="menu-item-8643" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-8643"><a href="http://karnac.com/flanews/topics/tracks/">Tracks</a>
<ul  class="sub-menu">
	<li id="menu-item-22978" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22978"><a href="http://karnac.com/flanews/topics/tracks/all-tech-raceway/">All-Tech Raceway</a></li>
	<li id="menu-item-8645" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-8645"><a href="http://karnac.com/flanews/topics/tracks/auburndale-speedway/">Auburndale Speedway</a></li>
	<li id="menu-item-11929" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11929"><a href="http://karnac.com/flanews/topics/tracks/ocala-speedway/">Bubba Raceway Park</a></li>
	<li id="menu-item-8646" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8646"><a href="http://karnac.com/flanews/topics/tracks/citrus-county-speedway/">Citrus County Speedway</a></li>
	<li id="menu-item-8648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8648"><a href="http://karnac.com/flanews/topics/tracks/east-bay-raceway-park/">East Bay Raceway Park</a></li>
	<li id="menu-item-12217" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12217"><a href="http://karnac.com/flanews/topics/tracks/five-flags-speedway/">Five Flags Speedway</a></li>
	<li id="menu-item-17358" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17358"><a href="http://karnac.com/flanews/topics/tracks/full-throttle-speedway/">Desoto Speedway</a></li>
	<li id="menu-item-23947" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23947"><a href="http://karnac.com/flanews/topics/tracks/golden-isle-speedway/">Golden Isle Speedway</a></li>
	<li id="menu-item-13161" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13161"><a href="http://karnac.com/flanews/topics/tracks/new-smyrna-speedway/">New Smyrna Speedway</a></li>
	<li id="menu-item-22979" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22979"><a href="http://karnac.com/flanews/topics/tracks/north-florida-speedway/">North Florida Speedway</a></li>
	<li id="menu-item-13370" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13370"><a href="http://karnac.com/flanews/topics/tracks/orlando-speedworld/">Orlando Speedworld</a></li>
	<li id="menu-item-12399" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12399"><a href="http://karnac.com/flanews/topics/tracks/showtime-speedway/">Showtime Speedway</a></li>
	<li id="menu-item-22975" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22975"><a href="http://karnac.com/flanews/topics/tracks/volusia-speedway-park/">Volusia Speedway Park</a></li>
</ul>
</li>
<li id="menu-item-8199" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-8199"><a href="http://karnac.com/flanews/topics/series/">Series</a>
<ul  class="sub-menu">
	<li id="menu-item-12972" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-12972"><a href="http://karnac.com/flanews/topics/series/arca/">ARCA</a>
	<ul  class="sub-menu">
		<li id="menu-item-12446" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12446"><a href="http://karnac.com/flanews/topics/series/cra-racing-series/">CRA Racing Series</a></li>
	</ul>
</li>
	<li id="menu-item-25274" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-25274"><a href="http://karnac.com/flanews/topics/series/dirtcar/">DIRTcar</a>
	<ul  class="sub-menu">
		<li id="menu-item-12640" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12640"><a href="http://karnac.com/flanews/topics/series/world-of-outlaws/super-dirtcar-series/">Super DIRTcar Series</a></li>
	</ul>
</li>
	<li id="menu-item-16032" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16032"><a href="http://karnac.com/flanews/topics/series/fastrak-late-model-series/">Fastrak Late Model Series</a></li>
	<li id="menu-item-13036" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13036"><a href="http://karnac.com/flanews/topics/series/imca/">IMCA</a></li>
	<li id="menu-item-12447" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12447"><a href="http://karnac.com/flanews/topics/series/lucas-oil-late-model-dirt-series/">Lucas Oil Late Model Dirt Series</a></li>
	<li id="menu-item-13487" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13487"><a href="http://karnac.com/flanews/topics/series/mars-dirtcar-series/">MARS DIRTcar Series</a></li>
	<li id="menu-item-12913" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12913"><a href="http://karnac.com/flanews/topics/series/nesmith-chevrolet-dirt-late-model-series/">NeSmith Chevrolet Dirt Late Model Series</a></li>
	<li id="menu-item-12504" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12504"><a href="http://karnac.com/flanews/topics/series/pro-all-stars-series/">Pro All Stars Series</a></li>
	<li id="menu-item-12924" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12924"><a href="http://karnac.com/flanews/topics/series/southern-all-stars/">Southern All Stars</a></li>
	<li id="menu-item-20552" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20552"><a href="http://karnac.com/flanews/topics/series/southern-super-series/">Southern Super Series</a></li>
	<li id="menu-item-8657" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8657"><a href="http://karnac.com/flanews/topics/series/top-gun-sprints/">Top Gun Sprints</a></li>
	<li id="menu-item-12491" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12491"><a href="http://karnac.com/flanews/topics/series/uara-stars/">UARA-STARS</a></li>
	<li id="menu-item-17503" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17503"><a href="http://karnac.com/flanews/topics/series/ultimate-super-late-model-seires/">ULTIMATE Super Late Model Seires</a></li>
	<li id="menu-item-24417" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24417"><a href="http://karnac.com/flanews/topics/series/usac-racing/">USAC Racing</a></li>
	<li id="menu-item-12515" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12515"><a href="http://karnac.com/flanews/topics/series/artic-cat-all-star-circuit-of-champions/">Artic Cat All Star Circuit of Champions</a></li>
	<li id="menu-item-12054" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-12054"><a href="http://karnac.com/flanews/topics/series/world-of-outlaws/">World of Outlaws</a>
	<ul  class="sub-menu">
		<li id="menu-item-12646" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12646"><a href="http://karnac.com/flanews/topics/series/world-of-outlaws/sprint-cars/">Sprint Cars</a></li>
		<li id="menu-item-12639" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12639"><a href="http://karnac.com/flanews/topics/series/world-of-outlaws/late-models/">Late Models</a></li>
		<li id="menu-item-23948" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23948"><a href="http://karnac.com/flanews/topics/series/world-of-outlaws/dirtcar-summer-nationals/">DIRTcar Racing</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-11923" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11923"><a href="http://karnac.com/flanews/topics/race-results/">Race Results</a></li>
<li id="menu-item-11925" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-11925"><a href="http://karnac.com/flanews/topics/upcoming-events/">Upcoming Events</a></li>
<li id="menu-item-12068" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12068"><a href="http://karnac.com/flanews/topics/series/racing-news/">Racing News</a></li>
<li id="menu-item-11961" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11961"><a href="http://www.realracinusa.com/forums/">Message Board</a></li>
</ul></div>                        </div>
                        <div class="responsive-slick-menu clearfix"></div>
                    </nav>
                    <!-- #site-navigation -->
	                                </div>
                <!-- .header-container -->
            </div>
            <!-- header-wrapper-->
        </header>
        <!-- #masthead -->
            <div class="wrapper content-wrapper clearfix">
            <div id="content" class="site-content">
    	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
			
<article id="post-25302" class="post-25302 post type-post status-publish format-standard has-post-thumbnail hentry category-auburndale-speedway category-racing-news category-upcoming-events">
	<header class="entry-header">
		<h1 class="entry-title">AUBURNDALE SPEEDWAY KICKS OFF 2018 SEASON WITH 75 LAPS OF PRO TRUCK RACING SATURDAY NIGHT</h1>
		<div class="entry-meta">
			<span class="posted-on"><a href="http://karnac.com/flanews/tracks/auburndale-speedway/auburndale-speedway-kicks-off-2018-season-with-75-laps-of-pro-truck-racing-saturday-night/" rel="bookmark"><i class="fa fa-calendar"></i><time class="entry-date published updated" datetime="2018-01-24T16:59:56+00:00">January 24, 2018</time></a></span><span class="byline"> <span class="author vcard"><a class="url fn n" href="http://karnac.com/flanews/author/scott/"><i class="fa fa-user"></i>Scott</a></span></span>		</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

	<!--post thumbnal options-->
			<div class="single-feat clearfix">
			<figure class="single-thumb single-thumb-full">
				<img width="960" height="786" src="http://karnac.com/flanews/wp-content/uploads/2018/01/2018-Season-Opener.jpg" class="attachment-full size-full wp-post-image" alt="" srcset="http://karnac.com/flanews/wp-content/uploads/2018/01/2018-Season-Opener.jpg 960w, http://karnac.com/flanews/wp-content/uploads/2018/01/2018-Season-Opener-768x629.jpg 768w" sizes="(max-width: 960px) 100vw, 960px" data-attachment-id="25303" data-permalink="http://karnac.com/flanews/tracks/auburndale-speedway/auburndale-speedway-kicks-off-2018-season-with-75-laps-of-pro-truck-racing-saturday-night/attachment/2018-season-opener/" data-orig-file="http://karnac.com/flanews/wp-content/uploads/2018/01/2018-Season-Opener.jpg" data-orig-size="960,786" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="2018 Season Opener" data-image-description="" data-medium-file="http://karnac.com/flanews/wp-content/uploads/2018/01/2018-Season-Opener-660x365.jpg" data-large-file="http://karnac.com/flanews/wp-content/uploads/2018/01/2018-Season-Opener-840x786.jpg" />			</figure>
		</div><!-- .single-feat-->
		<div class="entry-content">
		<p>Auburndale Speedway Gets the 2018 racing season under way in a big way this Saturday night with the Super Bowl 75 for the Pro Trucks headlining the racing card. Also in action will be the Legend Cars, V-8 Bombers, Q Mini Stocks, Mini Cup cars and the Scramblers.</p>
<p>Among the Pro Truck drivers expected are Rodney and Blake Haddock from Hilliard who will be making their first start here in some time, Derek Pugh of Crystal River, Palmetto&#8217;s Jason Lester, Auburndale drivers William Kerns and Colt Cecil, Tyler Davis and Cody McDuffie of Lakeland, Pinellas Park&#8217;s Devin Kyle, Mike Kohut of Lehigh Acres and several more.</p>
<p>This 75-lap event pays a cool $1300 to win plus a $75 bonus for the fast qualifier. The event is the first of 11 total for the Pro Trucks in 2018.<br />
All others will be 50 laps in length with the exception of September 22nd when the Pro Trucks will run twin 25-lap races.</p>
<p>Pit gates open at 3 pm with practice slated from 4-5:30 pm. Grandstand gates open at 5 pm and qualifying for the Pro Trucks is slated for 6:15 pm. Racing begins at 7 pm with 8-lap heat races for the Mini Cups, Q Mini Stocks, Scramblers, Legend Cars and V-8 Bombers. Following intermission it&#8217;s time to go feature racing starting out with three 20-lap contests for the Mini Cups, Q Mini Stocks and Scramblers. The Legend Cars then go for 25 laps with the V-8 Bombers up next, also for 25 laps. The evening concludes with the Super Bowl<br />
75 for the Pro Trucks.</p>
<p>Adult admission for this great evening of action is just $15 with seniors 55+ $13. Children ages 5-12 are only $5 and all kids 4 and under get in free.<br />
The family 4-pack is just $32 for two adult and two children’s admissions (a $40 value). Pit passes are $30 per person and all parking is free.<br />
Auburndale Speedway no longer accepts credit cards due to the excessive charges being levied on the track by the credit card companies, however there is now an ATM on site for race fans to use.</p>
<p>NOTES:</p>
<p>Weather is expected to be nice for the season opener with a high temperature of 76 degrees and race time temperatures in the mid-upper 60s. There is a slight chance of precipitation very late Saturday night but the wet stuff should hold off until Sunday in advance of a cold front.</p>
<p>The Daytona Antique Auto Racing Association will once again hold their annual Winternationals at Auburndale Speedway. Dates will be February 22-24 and over<br />
100 classic Stock Cars, Modifieds, Speedsters, Sprint Cars and Midgets are expected to fill the pits.</p>
<p>Auburndale Speedway is starting a new 4-cylinder Pure Stock beginners division to get more people interested in racing at an affordable price. The plan is to have the first race on March 3rd if enough cars are ready. Remember, this is non race-experienced class for beginners ages 12 and up. If you are in need of a car to go racing with, contact the speedway and we will give you a good idea on where to get one.</p>
<p>Race fans should like this&#8230; For all Late Model events, if there is a rain-out on Saturday, the races will be run the next day on Sunday with racing starting at 2 pm.</p>
<p>Several marketing partners have re-upped with Auburndale Speedway and will be sponsoring various race night throughout the year. They include Q Auto and Injury Attorneys (who once again will be sponsoring the Mini Stock class), Harvest Meat Markets, DARN apparel (who will be once again helping local FFA school organizations) and 97.5 WPCV Country Radio.</p>
<p>The Lights, Camera, Traction! (LCT) Mini Cup Championship Series at Auburndale Speedway will once again be presented by Gordon Motorsports as a driver development class. This class is committed to helping young drivers develop a solid foundation for their racing careers and there are some changes to how things are being done in 2018.<br />
The Series allows anyone under 22 years of age to compete as a LCT Champ driver. Drivers over 22 can apply to run as a LCT Mentor driver. The sole role of LCT Mentor drivers is to assist in the development of young drivers.<br />
Mentor drivers are required to demonstrate exemplary leadership and sportsmanship qualities, both on and off track.<br />
Although the entire field will be running for the purse, one major change this year is that victory lane will be reserved for the top three kids giving them a chance to be interviewed and work on their media skills all while having their moment in the spotlight.<br />
Currently the class has two Mentor Drivers: Bill Rychel #71 and several time track champion Russell Bush, driver of the #8 car. Gordon Motorsports will also be providing a new Mini Cup to Doug Herrin, Douglas Herrin, Jr.&#8217;s father, as our first official GMS/LCT father/son team and and Doug, Sr. will be joining his son in the field soon.<br />
Gordon Motorsports is also looking for kids that would like to get involved with the production side of LCT. Whether in front of the camera as a pit reporter or behind the camera as a photographer or videographer, anyone interested can learn more by visiting LightsCameraTraction.org, or by calling 1-800-210-2995. You do not have to be a driver in the class to take part.</p>
<div style=""><div style="display:inline;"><a href="http://twitter.com/share?url=http%3A%2F%2Fkarnac.com%2Fflanews%2Ftracks%2Fauburndale-speedway%2Fauburndale-speedway-kicks-off-2018-season-with-75-laps-of-pro-truck-racing-saturday-night%2F" class="twitter-share-button" data-count="horizontal">Tweet</a><script type="text/javascript" src="http://platform.twitter.com/widgets.js"></script></div><div style="display:inline;"><iframe src="http://www.facebook.com/plugins/like.php?href=http%3A%2F%2Fkarnac.com%2Fflanews%2Ftracks%2Fauburndale-speedway%2Fauburndale-speedway-kicks-off-2018-season-with-75-laps-of-pro-truck-racing-saturday-night%2F&amp;send=false&amp;layout=button_count&amp;width=120&amp;show_faces=false&amp;action=like&amp;colorscheme=light&amp;font&amp;height=21" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:120px; height:21px;" allowTransparency="true"></iframe></div><div style="display:inline;"><g:plusone size="medium" href="http://karnac.com/flanews/tracks/auburndale-speedway/auburndale-speedway-kicks-off-2018-season-with-75-laps-of-pro-truck-racing-saturday-night/"></g:plusone><script type="text/javascript">(function() { var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true; po.src = 'https://apis.google.com/js/plusone.js'; var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s); })();</script></div></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><div class="fb-share-button" data-href="http://karnac.com/flanews/tracks/auburndale-speedway/auburndale-speedway-kicks-off-2018-season-with-75-laps-of-pro-truck-racing-saturday-night/" data-layout="button_count"></div></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://karnac.com/flanews/tracks/auburndale-speedway/auburndale-speedway-kicks-off-2018-season-with-75-laps-of-pro-truck-racing-saturday-night/" data-text="AUBURNDALE SPEEDWAY KICKS OFF 2018 SEASON WITH 75 LAPS OF PRO TRUCK RACING SATURDAY NIGHT"  >Tweet</a></li><li class="share-google-plus-1"><div class="googleplus1_button"><div class="g-plus" data-action="share" data-annotation="bubble" data-href="http://karnac.com/flanews/tracks/auburndale-speedway/auburndale-speedway-kicks-off-2018-season-with-75-laps-of-pro-truck-racing-saturday-night/"></div></div></li><li class="share-linkedin"><div class="linkedin_button"><script type="in/share" data-url="http://karnac.com/flanews/tracks/auburndale-speedway/auburndale-speedway-kicks-off-2018-season-with-75-laps-of-pro-truck-racing-saturday-night/" data-counter="right"></script></div></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button" href="http://karnac.com/flanews/tracks/auburndale-speedway/auburndale-speedway-kicks-off-2018-season-with-75-laps-of-pro-truck-racing-saturday-night/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-end"></li></ul></div></div></div>			</div><!-- .entry-content -->

	<footer class="entry-footer featured-desc">
		<span class="cat-links"><i class="fa fa-folder-o"></i><a href="http://karnac.com/flanews/topics/tracks/auburndale-speedway/" rel="category tag">Auburndale Speedway</a>, <a href="http://karnac.com/flanews/topics/racing-news/" rel="category tag">Racing News</a>, <a href="http://karnac.com/flanews/topics/upcoming-events/" rel="category tag">Upcoming Events</a></span>	</footer><!-- .entry-footer -->
</article><!-- #post-## -->


	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="http://karnac.com/flanews/upcoming-events/volusia-speedway-park-gets-a-300000-safety-upgrade-for-dirtcar-nationals/" rel="prev">Volusia Speedway Park Gets a $300,000 Safety Upgrade for DIRTcar Nationals</a></div></div>
	</nav>                <h2 class="widget-title">
			        Related posts                </h2>
		                    <ul class="featured-entries-col featured-entries featured-col-posts featured-related-posts">
		                            <li class="acme-col-3">
                        <figure class="widget-image">
                            <a href="http://karnac.com/flanews/upcoming-events/volusia-speedway-park-gets-a-300000-safety-upgrade-for-dirtcar-nationals/">
						        <img width="640" height="320" src="http://karnac.com/flanews/wp-content/uploads/2018/01/2018_DCN_ImprovementsDC.jpg" class="attachment-large size-large wp-post-image" alt="" data-attachment-id="25300" data-permalink="http://karnac.com/flanews/upcoming-events/volusia-speedway-park-gets-a-300000-safety-upgrade-for-dirtcar-nationals/attachment/2018_dcn_improvementsdc/" data-orig-file="http://karnac.com/flanews/wp-content/uploads/2018/01/2018_DCN_ImprovementsDC.jpg" data-orig-size="660,330" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="2018_DCN_ImprovementsDC" data-image-description="" data-medium-file="http://karnac.com/flanews/wp-content/uploads/2018/01/2018_DCN_ImprovementsDC-660x330.jpg" data-large-file="http://karnac.com/flanews/wp-content/uploads/2018/01/2018_DCN_ImprovementsDC.jpg" />                            </a>
                        </figure>
                        <div class="featured-desc">
                            <div class="above-entry-meta">
						                                        <span>
                                    <a href="http://karnac.com/flanews/2018/01/24/">
                                        <i class="fa fa-calendar"></i>
	                                    January 24, 2018                                    </a>
                                </span>
                                <span>
                                    <a href="http://karnac.com/flanews/author/scott/" title="Scott">
                                        <i class="fa fa-user"></i>
	                                    Scott                                    </a>
                                </span>
                                <span>
                                    <span>Comments Off<span class="screen-reader-text"> on Volusia Speedway Park Gets a $300,000 Safety Upgrade for DIRTcar Nationals</span></span>                                </span>
                            </div>
                            <a href="http://karnac.com/flanews/upcoming-events/volusia-speedway-park-gets-a-300000-safety-upgrade-for-dirtcar-nationals/">
                                <h4 class="title">
							        Volusia Speedway Park Gets a $300,000 Safety Upgrade for DIRTcar Nationals                                </h4>
                            </a>
					        <div class="details">BABERVILLE, FL — Jan. 23, 2018 — In honor of Volusia Speedway Park’s 50th anniversary, the...</div>                            <div class="below-entry-meta">
						        <span class="cat-links"><a class="at-cat-item-61" href="http://karnac.com/flanews/topics/racing-news/"  rel="category tag">Racing News</a>&nbsp;<a class="at-cat-item-21" href="http://karnac.com/flanews/topics/upcoming-events/"  rel="category tag">Upcoming Events</a>&nbsp;</span>                            </div>
                        </div>
                    </li>
			                            <li class="acme-col-3">
                        <figure class="widget-image">
                            <a href="http://karnac.com/flanews/racing-news/cars-tour-to-host-and-sanction-two-limited-late-model-races-in-2018/">
						        <img width="640" height="351" src="http://karnac.com/flanews/wp-content/uploads/2017/06/cars-tour-logo-840x461.jpg" class="attachment-large size-large wp-post-image" alt="" data-attachment-id="24765" data-permalink="http://karnac.com/flanews/front-page-news/cars-tour-announces-format-for-slm-10000-to-win-mid-atlantic-classic-at-orange-county-speedway-july-22/attachment/cars-tour-logo-3/" data-orig-file="http://karnac.com/flanews/wp-content/uploads/2017/06/cars-tour-logo.jpg" data-orig-size="860,461" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="cars-tour-logo" data-image-description="" data-medium-file="http://karnac.com/flanews/wp-content/uploads/2017/06/cars-tour-logo-660x365.jpg" data-large-file="http://karnac.com/flanews/wp-content/uploads/2017/06/cars-tour-logo-840x461.jpg" />                            </a>
                        </figure>
                        <div class="featured-desc">
                            <div class="above-entry-meta">
						                                        <span>
                                    <a href="http://karnac.com/flanews/2018/01/24/">
                                        <i class="fa fa-calendar"></i>
	                                    January 24, 2018                                    </a>
                                </span>
                                <span>
                                    <a href="http://karnac.com/flanews/author/scott/" title="Scott">
                                        <i class="fa fa-user"></i>
	                                    Scott                                    </a>
                                </span>
                                <span>
                                    <span>Comments Off<span class="screen-reader-text"> on CARS Tour to Host and Sanction Two Limited Late Model Races in 2018</span></span>                                </span>
                            </div>
                            <a href="http://karnac.com/flanews/racing-news/cars-tour-to-host-and-sanction-two-limited-late-model-races-in-2018/">
                                <h4 class="title">
							        CARS Tour to Host and Sanction Two Limited Late Model Races in 2018                                </h4>
                            </a>
					        <div class="details">Mooresville, NC 1/23/18 – With the huge Mountain Dew “Do The Dew” 150, on March 10th, already...</div>                            <div class="below-entry-meta">
						        <span class="cat-links"><a class="at-cat-item-107" href="http://karnac.com/flanews/topics/series/cars-racing-tour/"  rel="category tag">CARS Racing Tour</a>&nbsp;<a class="at-cat-item-61" href="http://karnac.com/flanews/topics/racing-news/"  rel="category tag">Racing News</a>&nbsp;</span>                            </div>
                        </div>
                    </li>
			                            <li class="acme-col-3">
                        <figure class="widget-image">
                            <a href="http://karnac.com/flanews/upcoming-events/pass-super-late-models-to-headline-inaugural-commonwealth-classic-at-richmond-raceway/">
						        <img width="380" height="158" src="http://karnac.com/flanews/wp-content/uploads/2018/01/380web-PASS-2006-M.png" class="attachment-large size-large wp-post-image" alt="" data-attachment-id="25295" data-permalink="http://karnac.com/flanews/upcoming-events/pass-super-late-models-to-headline-inaugural-commonwealth-classic-at-richmond-raceway/attachment/380web-pass-2006-m-3/" data-orig-file="http://karnac.com/flanews/wp-content/uploads/2018/01/380web-PASS-2006-M.png" data-orig-size="380,158" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="380web-PASS-2006-M" data-image-description="" data-medium-file="http://karnac.com/flanews/wp-content/uploads/2018/01/380web-PASS-2006-M.png" data-large-file="http://karnac.com/flanews/wp-content/uploads/2018/01/380web-PASS-2006-M.png" />                            </a>
                        </figure>
                        <div class="featured-desc">
                            <div class="above-entry-meta">
						                                        <span>
                                    <a href="http://karnac.com/flanews/2018/01/23/">
                                        <i class="fa fa-calendar"></i>
	                                    January 23, 2018                                    </a>
                                </span>
                                <span>
                                    <a href="http://karnac.com/flanews/author/scott/" title="Scott">
                                        <i class="fa fa-user"></i>
	                                    Scott                                    </a>
                                </span>
                                <span>
                                    <span>Comments Off<span class="screen-reader-text"> on PASS Super Late Models  To Headline Inaugural  Commonwealth Classic  At Richmond Raceway</span></span>                                </span>
                            </div>
                            <a href="http://karnac.com/flanews/upcoming-events/pass-super-late-models-to-headline-inaugural-commonwealth-classic-at-richmond-raceway/">
                                <h4 class="title">
							        PASS Super Late Models  To Headline Inaugural  Commonwealth Classic  At Richmond Raceway                                </h4>
                            </a>
					        <div class="details">PASS National Championship Event Will Be 100 Laps, Paying $10,000 To Win &amp; $700 To Start...</div>                            <div class="below-entry-meta">
						        <span class="cat-links"><a class="at-cat-item-67" href="http://karnac.com/flanews/topics/series/pro-all-stars-series/"  rel="category tag">Pro All Stars Series</a>&nbsp;<a class="at-cat-item-61" href="http://karnac.com/flanews/topics/racing-news/"  rel="category tag">Racing News</a>&nbsp;<a class="at-cat-item-21" href="http://karnac.com/flanews/topics/upcoming-events/"  rel="category tag">Upcoming Events</a>&nbsp;</span>                            </div>
                        </div>
                    </li>
			                    </ul>
            <div class="clearfix"></div>
	        
		</main><!-- #main -->
	</div><!-- #primary -->
	<div id="secondary-right" class="widget-area sidebar secondary-sidebar float-right" role="complementary">
		<div id="sidebar-section-top" class="widget-area sidebar clearfix">
					<aside id="recent-posts-5" class="widget widget_recent_entries">		<h3 class="widget-title"><span>Recent Posts</span></h3>		<ul>
					<li>
				<a href="http://karnac.com/flanews/tracks/auburndale-speedway/auburndale-speedway-kicks-off-2018-season-with-75-laps-of-pro-truck-racing-saturday-night/">AUBURNDALE SPEEDWAY KICKS OFF 2018 SEASON WITH 75 LAPS OF PRO TRUCK RACING SATURDAY NIGHT</a>
						</li>
					<li>
				<a href="http://karnac.com/flanews/upcoming-events/volusia-speedway-park-gets-a-300000-safety-upgrade-for-dirtcar-nationals/">Volusia Speedway Park Gets a $300,000 Safety Upgrade for DIRTcar Nationals</a>
						</li>
					<li>
				<a href="http://karnac.com/flanews/racing-news/cars-tour-to-host-and-sanction-two-limited-late-model-races-in-2018/">CARS Tour to Host and Sanction Two Limited Late Model Races in 2018</a>
						</li>
					<li>
				<a href="http://karnac.com/flanews/upcoming-events/pass-super-late-models-to-headline-inaugural-commonwealth-classic-at-richmond-raceway/">PASS Super Late Models  To Headline Inaugural  Commonwealth Classic  At Richmond Raceway</a>
						</li>
					<li>
				<a href="http://karnac.com/flanews/upcoming-events/weather-forecast-results-in-major-cra-speedfest-2018-schedule-changes/">Weather Forecast Results in Major CRA SpeedFest 2018 Schedule Changes</a>
						</li>
					<li>
				<a href="http://karnac.com/flanews/tracks/east-bay-raceway-park/dirtcar-ump-modifieds-to-race-14-times-in-florida-in-januaryfebruary/">DIRTcar UMP Modifieds to Race 14 Times in Florida in January/February</a>
						</li>
					<li>
				<a href="http://karnac.com/flanews/tracks/volusia-speedway-park/dirtcar-ump-modifieds-kick-off-47th-annual-dirtcar-nationals-at-volusia-speedway-park/">DIRTcar UMP Modifieds Kick Off 47th Annual DIRTcar Nationals at Volusia Speedway Park</a>
						</li>
					<li>
				<a href="http://karnac.com/flanews/series/lucas-oil-late-model-dirt-series/new-format-leads-to-bigger-richer-topless-100-in-2018/">New Format Leads to Bigger, Richer Topless 100 in 2018!</a>
						</li>
					<li>
				<a href="http://karnac.com/flanews/racing-news/brandon-ford-wheel-man-sportsman-series-welcomes-two-new-tracks-for-2018-season/">Brandon Ford Wheel Man Sportsman Series Welcomes Two New Tracks For 2018 Season</a>
						</li>
					<li>
				<a href="http://karnac.com/flanews/upcoming-events/southern-all-stars-2018-schedule-release/">Southern All Stars 2018 Schedule Release</a>
						</li>
				</ul>
		</aside>		<aside id="text-114" class="widget widget_text">			<div class="textwidget"><!-- Karnac.com 300x600 [async] -->
<script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'http://ads.1motorsport.com/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script>
<script type="text/javascript">
var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
var abkw = window.abkw || '';
var plc207498 = window.plc207498 || 0;
document.write('<'+'div id="placement_207498_'+plc207498+'"></'+'div>');
AdButler.ads.push({handler: function(opt){ AdButler.register(165890, 207498, [300,600], 'placement_207498_'+opt.place, opt); }, opt: { place: plc207498++, keywords: abkw, domain: 'ads.1motorsport.com', click:'CLICK_MACRO_PLACEHOLDER' }});
</script></div>
		</aside><aside id="text-113" class="widget widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 300x250 Tower Ad -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-8957007654552288"
     data-ad-slot="7505581171"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside><aside id="facebook-likebox-4" class="widget widget_facebook_likebox">		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/karnacracing/" data-width="350"  data-height="580" data-hide-cover="false" data-show-facepile="true" data-show-posts="true">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/karnacracing/"><a href="https://www.facebook.com/karnacracing/"></a></blockquote></div>
		</div>
		</aside>		</div>
	</div>
        </div><!-- #content -->
        </div><!-- content-wrapper-->
            <div class="clearfix"></div>
        <footer id="colophon" class="site-footer" role="contentinfo">
            <div class="footer-wrapper">
                <div class="top-bottom wrapper">
                    <div id="footer-top">
                        <div class="footer-columns">
                                                   </div>
                    </div><!-- #foter-top -->
                    <div class="clearfix"></div>
                 </div><!-- top-bottom-->
                <div class="wrapper footer-copyright border text-center">
                    <p>
                                                    Copyright &copy; All rights reserved                                            </p>
                    <div class="site-info">
                    <a href="https://wordpress.org/">Proudly powered by WordPress</a>
                    <span class="sep"> | </span>
                    Theme: SuperMag by <a href="https://www.acmethemes.com/" rel="designer">Acme Themes</a>.                    </div><!-- .site-info -->
                </div>
            </div><!-- footer-wrapper-->
        </footer><!-- #colophon -->
            </div><!-- #page -->
    <script language="javascript" type="text/javascript">var kpg_cell="N";var kpg_nrci_image="http://karnac.com/flanews/wp-content/plugins/no-right-click-images-plugin/not.gif";var kpg_nrci_extra="Y";var kpg_nrci_drag="Y";</script>
<script language="javascript" type="text/javascript" src="http://karnac.com/flanews/wp-content/plugins/no-right-click-images-plugin/no-right-click-images.js"></script>

    <!-- Start of StatCounter Code -->
    <script>
    <!-- 
        var sc_project=9187603; 
        var sc_security="c4c5fbcb"; 
        var scJsHost = (("https:" == document.location.protocol) ?
        "https://secure." : "http://www.");
    //-->
document.write("<sc"+"ript src='" +scJsHost +"statcounter.com/counter/counter.js'></"+"script>");
</script>
<noscript><div class="statcounter"><a title="web analytics" href="https://statcounter.com/"><img class="statcounter" src="https://c.statcounter.com/9187603/0/c4c5fbcb/0/" alt="web analytics" /></a></div></noscript>   
    <!-- End of StatCounter Code -->
<script type="text/javascript">
disableSelection(document.body)
</script>
<small>Copy Protected by <a href="http://chetangole.com/" target="_blank">Chetan</a>'s <a href="http://chetangole.com/blog/wp-copyprotect/" target="_blank">WP-Copyprotect</a>.</small>
	<div style="display:none">
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/karnac.com\/flanews\/tracks\/auburndale-speedway\/auburndale-speedway-kicks-off-2018-season-with-75-laps-of-pro-truck-racing-saturday-night\/":25302};
	</script>
<div id="fb-root"></div>
			<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
			<script>
			jQuery( document.body ).on( 'post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
						<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
						<script>
			function renderGooglePlus1() {
				if ( 'undefined' === typeof gapi ) {
					return;
				}

				jQuery( '.g-plus' ).each(function() {
					var $button = jQuery( this );

					if ( ! $button.data( 'gplus-rendered' ) ) {
						gapi.plusone.render( this, {
							href: $button.attr( 'data-href' ),
							size: $button.attr( 'data-size' ),
							annotation: $button.attr( 'data-annotation' )
						});

						$button.data( 'gplus-rendered', true );
					}
				});
			}

			(function() {
				var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
				po.src = 'https://apis.google.com/js/plusone.js';
				po.innerHTML = '{"parsetags": "explicit"}';
				po.onload = renderGooglePlus1;
				var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
			})();

			jQuery( document.body ).on( 'post-load', renderGooglePlus1 );
			</script>
			<script type="text/javascript">
			jQuery( document ).ready( function() {
				jQuery.getScript( 'https://platform.linkedin.com/in.js?async=true', function success() {
					IN.init();
				});
			});
			jQuery( document.body ).on( 'post-load', function() {
				if ( typeof IN != 'undefined' )
					IN.parse();
			});
			</script>	<div id="sharing_email" style="display: none;">
		<form action="/flanews/tracks/auburndale-speedway/auburndale-speedway-kicks-off-2018-season-with-75-laps-of-pro-truck-racing-saturday-night/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
			
			<img style="float: right; display: none" class="loading" src="http://karnac.com/flanews/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201804'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2018Janaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://karnac.com/flanews/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.8.5'></script>
<script type='text/javascript' src='http://karnac.com/flanews/wp-content/themes/supermag/assets/library/bxslider/js/jquery.bxslider.min.js?ver=4.2.5'></script>
<script type='text/javascript' src='http://karnac.com/flanews/wp-content/themes/supermag/assets/library/theia-sticky-sidebar/theia-sticky-sidebar.js?ver=1.4.0'></script>
<script type='text/javascript' src='http://karnac.com/flanews/wp-content/themes/supermag/assets/js/supermag-custom.js?ver=1.4.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='http://karnac.com/flanews/wp-content/plugins/jetpack/_inc/facebook-embed.js'></script>
<script type='text/javascript' src='http://karnac.com/flanews/wp-includes/js/wp-embed.min.js?ver=4.8.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://karnac.com/flanews/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=5.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201804.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.1',blog:'56483510',post:'25302',tz:'0',srv:'karnac.com'} ]);
	_stq.push([ 'clickTrackerInit', '56483510', '25302' ]);
</script>
</body>
</html>
<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Page Caching using disk: enhanced

 Served from: karnac.com @ 2018-01-24 20:55:54 by W3 Total Cache -->